Delay in application submissions

Incident Report for talentsconnect operations GmbH

Postmortem

Incident Report: Application Forwarding Disruption, April 8-10, 2026

Summary

Between April 8 at approximately 17:15 CEST and April 10 at 00:30 CEST, application forwarding to ATS systems and recruiter inboxes was disrupted. Applications submitted by candidates during this period were received and queued for delivery. Approximately 4,000 applications experienced a delay in forwarding to your systems. All queued applications have since been successfully delivered.

What happened

On April 8, an unusually high volume of automated API requests caused a memory overload in the service responsible for processing and forwarding applications. The overload caused the forwarding component to stop while the rest of the service continued operating normally. Because our health monitoring did not specifically track the state of the forwarding component, the issue was not detected automatically.

The issue was reported to us by a customer on April 9 at approximately 14:00 CEST. Our engineering team identified the root cause within one hour and deployed a fix by 17:00 CEST. Application forwarding resumed immediately, and the full backlog of delayed applications was processed and delivered by 00:30 CEST on April 10.

Impact

All customers using application forwarding (ATS integrations and email-based delivery) were affected during this window. Candidates were able to submit applications normally throughout the incident, and all submissions were successfully forwarded once the issue was resolved. Delivery to recruiters was delayed by 5 hours on average, and up to 31 hours for applications submitted at the start of the incident window.

What we have done

  1. Improved health monitoring: Our service health checks now actively monitor the state of the application forwarding component. If it stops, the system will automatically detect the failure and restart the service within minutes.
  2. Added delivery alerting: We have added a dedicated alert that triggers when application delivery volume drops to zero, enabling our team to respond proactively.
  3. Addressed the root cause: We have deployed input validation and rate controls on the API that caused the memory overload, preventing this type of resource exhaustion from recurring.
  4. Improved error resilience: We have added safeguards to ensure that individual message processing failures are isolated and cannot block delivery of other applications.

What we are doing next

  1. We are reviewing all other services for similar monitoring gaps to ensure health checks accurately reflect the state of all critical components.
  2. We are planning a dedicated, purpose-built export API for high-volume use cases to replace the legacy integration that triggered this incident.

Closing note

We understand that reliable and timely application delivery is critical to your recruiting operations. We take this incident seriously, and the improvements we have made are designed to ensure that a similar issue will be detected and resolved automatically in the future. We appreciate your patience and trust.

Posted Apr 10, 2026 - 14:17 CEST

Resolved

The issue has been resolved. Application forwarding is fully operational and all queued applications have been delivered. The root cause was a high-volume data export that overwhelmed the processing service. A targeted fix has been applied to prevent recurrence.
Posted Apr 09, 2026 - 23:10 CEST

Update

The issue has been identified and a fix has been applied. Application forwarding has resumed and queued applications are being delivered. We are monitoring to confirm all queued applications are fully processed. We will provide a final update once delivery is confirmed complete.
Posted Apr 09, 2026 - 17:45 CEST

Monitoring

The issue has been identified and a fix has been applied. Application forwarding has resumed and queued applications are being delivered. We are monitoring to confirm all queued applications are fully processed. We will provide a final update once delivery is confirmed complete.
Posted Apr 09, 2026 - 17:22 CEST

Identified

Root cause has been identified: a high-volume data export caused the application forwarding service to stop processing. Our engineering team is applying a fix now. Queued applications are intact and will be forwarded once processing resumes. We will update this incident when the fix is deployed.
Posted Apr 09, 2026 - 15:13 CEST

Investigating

Application forwarding to client ATS systems is currently not operational. Applications submitted since approximately 17:15 CEST on April 8 are queued and have not been delivered. Our engineering team is actively investigating the root cause. Queued applications are expected to be delivered once the issue is resolved. We will provide an update as soon as we have more information.
Posted Apr 09, 2026 - 14:39 CEST
This incident affected: Tier 1 / Critical - JobShop Candidate Facing Features (Candidate Service).