A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2026 - 18:14 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 04, 2026 - 09:12 CET
Identified
We are continuing to address an issue affecting the Page Editor and Moving pages to other Jobshops functionality.
What this means for you: You may encounter errors when attempting to open certain pages within the editor. Moving pages between Jobshops may be temporarily unsuccessful.
Our team is currently working on a solution. We expect to fix the root cause and be monitoring the results by February 6.
If you encounter a broken page or require immediate assistance, please reach out to us at support@talentsconnect.com. We apologize for the continued inconvenience and appreciate your patience.
Posted Feb 03, 2026 - 17:49 CET
This incident affected: Tier 2 / High - Recruiter Functionality (Recruiting Home).