The synchronization process has been completed. All affected jobs have been restored and should now be visible in both search results and job detail pages. We are continuing to monitor the system to ensure stability.
We appreciate your patience as we worked through this issue. If you notice any remaining problems with job visibility, please contact our support team.
A detailed postmortem will be shared in the coming days.
Posted Nov 20, 2025 - 17:15 CET
Update
Our team is systematically synchronizing the affected jobs between systems. This is a careful, step-by-step process to ensure all jobs are restored correctly. We're working through this steadily and making good progress. All job data is secure.
We'll update you again no later than 18:00 CET today.
Posted Nov 20, 2025 - 12:24 CET
Update
We are continuing to monitor for any further issues.
Posted Nov 19, 2025 - 16:48 CET
Monitoring
A small number of newly posted jobs are showing up in search results, but their corresponding job detail pages are returning 404 errors. The jobs that aren't showing up are ones that have been newly added to customers' JobShops since November 18 at 14:20 CET. This is affecting visibility of less than 1% of jobs across all talentsconnect customers.
No jobs have been lost. All job data is securely stored in our systems and will be synchronized once the issue is fully resolved.
Status: We have identified the root cause (Kafka consumer lag) and steps to restore access to these jobs is underway. We will provide a further update when all jobs are again visible.
Posted Nov 18, 2025 - 14:20 CET
This incident affected: Tier 2 / High - Recruiter Functionality (Recruiting Home) and Tier 1 / Critical - JobShop Candidate Facing Features (Candidate Frontend).