www.talentsconnect.com and www.pitchyou.de affected by CloudFlare incident/maintenance

Incident Report for talentsconnect operations GmbH

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 11:34 CET

Monitoring

Both www.talentsconnect.com and www.pitchyou.de are available again. We'll monitor the situation going forward and update this incident if there is new information.
Posted Dec 05, 2025 - 10:13 CET

Identified

Our websites www.talentsconnect.com and www.pitchyou.de are currently affected by the ongoing CloudFlare incident/maintenance, see https://www.cloudflarestatus.com for details.

Customer JobShops are not affected unless CloudFlare is used as a reverse proxy/WAF in front of the JobShop.
Posted Dec 05, 2025 - 10:08 CET
This incident affected: Tier 1 / Critical - JobShop Candidate Facing Features (PitchYou Portal).