JobShop slowness

Incident Report for talentsconnect AG

Postmortem

The slowness was caused by an unusual spike of offer updates from an external Applicant Tracking System. We are working with the provider to identify the trigger mechanism and will implement preventive measures on our end.

Posted Mar 31, 2025 - 13:00 CEST

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 12:03 CEST

Monitoring

A fix has been implemented and the latency is back to normal again.
Posted Mar 31, 2025 - 09:15 CEST

Investigating

We identified a higher latency for JobShop requests that started around 6:30. We are currently investigating the issue to identify the root cause.
Posted Mar 31, 2025 - 08:35 CEST
This incident affected: Tier 1 / Critical - JobShop Candidate Facing Features (Candidate Frontend).